Tag Archives: Eve Client

Premium Lite On The Way & Classic Becomes History

A recent series of dev blogs has highlighted a massive change to the Eve Online client system. Classic will be gone and in its place will be what CCP is calling “Premium Lite.”  The new Lite client is essentially the Premium client but with more options to turn down effects like most games on the market.

This is a big change for both players and CCP. I know personally I’ve been using the Classic client since day one. Its been fairly stable and allows running multiple clients without much fear of a framerate slow down. I still run Classic to this day, even though I’m running it on a hot rod of a system. I’ve toyed with switching to Premium, but why change what already works?

The big question that remains is how well the Premium Lite client will run. Can we expect Classic like performance with all the settings turned low? Most desktop users shouldn’t have a problem and CCP says any GeForce 5 or ATI R300 or higher series card should be able to handle the lite client (as always, take CCP specs with a massive grain of salt). The biggest problem comes to mind when you start talking about notebooks. Their graphics cards aren’t upgradeable in most cases. Netbooks that can run the Classic client have been popular recently. Eve is a game you can stay logged into for hours, mining or just chatting with buddies and corpmates. Having an affordable notebook to take with you and stay logged in makes a lot of sense.

All of this is great for CCP. This means they don’t have to create two seperate model groups for each graphics engine. This saves time and allows them to devote teams of designers and debuggers to other projects. Hopefully this means a much more stable client overall. They need to seriously work on how the game handles packet loss. The number of disconnects before matches during the past week of alliance tournaments was embarrassing.

I caution CCP about moving to quickly to drop support for older graphics cards. The fact of the matter is that some people, especially those on older notebooks, will not have the proper card to run the new Premium Lite. If this is their only way of logging in, then chances are they won’t be continuing their subscription. Cutting Shadermodel 2 will undoubtedly lose a few more subscriptions along the way. Things DO need to move forward but they need to stop at each stage and take a serious look at their client and the realistic performance it has on the cards they say are supported for it. My older computer had a 2ghz AMD processor with 2gb of ram and an Nvidia 6800 card and it had plenty of hiccups with the classic client. Saying that the Premium Lite client will support 5 series cards and up sounds like thats the minimum to be able to actually open and run the client. What is required to actually run the game with enjoyable performance is yet to be seen. Time will tell and if they can introduce a lite client with the performance to suit both newer and older systems then it could be a great win for both sides. We will all be waiting.

1 Comment

Filed under EvE News